AudioMulch Help > Automating AudioMulch Previous Next

Editing an Automation Sequence

Automation time splicing behaves in a similar fashion to the way text may be edited in a word processor, or the way sound files are edited in a sound file editor. You can set an insertion point or select a time range and apply familiar operations such as Cut, Copy, Paste and Delete Time and also use the Insert Time command to insert a specified amount of time. All of these operations are available from the Edit menu. The Automation view indicates the current selection as follows: An insertion point is indicated by a flashing vertical bar in the channels to which it applies. A selected time range appears as a highlighted background in the applicable channels.

Creating a Selection

The insertion point or selected time range can apply to any combination of automation channels. To select a time range spanning all channels, click and drag in the center region of the automation Time Ruler (the cursor will change to an I-beam to indicate that the mouse is in the time selection area). To set the insertion point across all channels click and release the mouse in the time selection area of the automation ruler. A selection range or insertion point can be made for an individual automation channel by clicking and dragging in empty space within the channel (the cursor changes to an I-beam to indicate the appropriate area from which to perform the selection). A selection spanning multiple channels may be created in similar fashion by beginning a selection on one channel and dragging the mouse across other channels to include them in the selection.

Modifying an Exisiting Selection

Once the insertion point has been set, or a time range has been selected, it is possible to modify the selection by holding down the SHIFT and/or CTRL keys on the keyboard while clicking or dragging with the mouse.

The selected time range can be modified by holding down the SHIFT key and clicking and dragging in the ruler, or in any channel which is currently part of the selection. By SHIFT-clicking before the beginning of the current selection range (or insertion point), the beginning of the selection can be modified. By SHIFT-clicking after the end of the current selection range, the end of the selection can be modified.

SHIFT-clicking can also be used to extend the selection across currently unselected channels. By SHIFT-clicking in an unselected channel, the channel and all channels between it and the current selection become part of the selection. SHIFT-clicking always modifies the start or end location of the selection, for this reason, using the CTRL key (see below) may be more useful for altering which channels are included in the selection.

It is possible to add or remove channels from an existing selection or insertion point by clicking while holding down the CTRL key on the keyboard. CTRL-clicking a channel within the selected time range will toggle the channel between being a member and not being a member of the selection (or insertion point.) A CTRL-click and drag across multiple channels will include or preclude them from the selection.

Insert Time

When the insertion point is set for one or more channels the Insert Time command from the Edit menu lets you insert a specified period of time into the selected channels. The time is specified in bars and beats, based on the time signature present at the insertion point.

Delete Time

To delete the selected time range in the selected channels, choose Delete Time from the Edit menu (CTRL+DELETE on the keyboard).

Cut, Copy and Clear

You can access Cut, Copy, Clear and Delete Time from the Edit menu. Use Cut and Copy to place the automation selection on the clipboard. When you use Cut, the selected time range will be removed from the selected channels. Select Clear (or use the DELETE key) to clear the automation points in the selected time range in the selected channels.


The Paste command from the Edit menu can be used to insert the contents of the clipboard into the automation selection. When an insertion point is selected, the Paste command will insert the time range in the clipboard into the automation view and push all following automation forward in time. When a time range is selected in the Automation view, Pasting will replace the selected time range with the time range on the Clipboard.

The Paste command behaves slightly differently depending on whether the Clipboard holds a clipping from only one automation channel, or if it holds clippings from multiple channels.

When the Clipboard contains only a single channel, a Paste operation may be performed on any compatible channel. Channels are considered compatible if they are of the same type (ie Trigger, Preset, Boolean (check box), Value or Range) and in the case of Value and Range channels the allowable value range must also match. Note that to use this Paste mode, the insertion point must not include multiple channels.

When the Clipboard contains more than one channel of automation information, data is always pasted into the same channel from which it was cut or copied. Irrespective of the number of channels on the Clipboard, a Paste operation only ever applies to the channels that are part of the selected range or insertion point – channels on the clipboard which are not selected are not pasted. When the selection spans multiple channels, and some of those channels are not present on the clipboard the Paste command will insert blank time into the channels not present on the clipboard.

Previous Next