trigger samples with Korg nanoPAD

4 posts / 0 new
Last post
Jos Smolders
Jos Smolders's picture
Joined: May 12, 2010

hi, just bought myself a nanopad (because they're dirt cheap and seem versatile).

My first goal is to trigger a file player at the tap of one of the pads. However it seems that letting go the pad is a note off command, causing the file player to stop immediately...... What it the right setting to enable the file player to play the entire file?

pgnnwy's picture
Joined: June 23, 2009

I'm at the wrong computer to answer this one properly, but I think you need to change the settings for the button in the nanokontrol software - from toggle to moment, or something.

Then I think you might need to either check or uncheck the 'toggle' box in 'parameter control' settings in Audiomulch (right click over the file player play button, select 'parameter control', choose the 'mapping' tab)

Play around with those two settings and I'm pretty sure you'll get there in the end.

Ross B.
Ross B.'s picture
Joined: April 11, 2009

You can also switch the mapping to Toggle in the Mapping tab of AudioMulch's Parameter Control window.

Cork City Gamelan
Cork City Gamelan's picture
Joined: July 27, 2012

I solved this nicely for myself. I am currently learning Max/MSP, and this was my first Max patch which does something useful. A similar or identical solution can probably cooked up with PD, which seems to be almost identical to Max, but it is open source freeware.

The Nanopad sends MIDI notes: "on" when you hit the pad, and "off" when you take your finger off the pad. "On" is the note number and the velocity number according to how hard you hit the pad. "Off" is the same note number with velocity set to "0".

1) I set the file player to "Auto Rewind".
2) In the parameter sources window, I choose "Note Velocity" and the note number I am using.

Now, when I play the pad, the file plays for as long as I keep my finger  on the pad - then it rewinds.

However, I want it to work like percussion: Hit the pad, and the file plays all the way to the end - unless I re-trigger it beforee it is finished - so:

3) in the parameter mapping window, I check "inverted".
4) I also set a very low threshold, say "2"

Now, when I hit the pad and let go very quickly, it works as it should. It would probably be fine with sticks on a drumhead - with a finger pad, though, I reckon this is just plain awful. So, I use Max to modify the MIDI which the pad sends out.

here is  picture of the patch:

It works like this:

1) The "notein" object (contraption, in AM terms) on the top reads the note events sent by the Nanopad, from left to right: note number, velocity, MIDI channel… as two sets of theree values, for "on" and "off" respectively.
2) "Stripnote" removes the note "off" information
3) The note number and note name boxes are for myself, for error checking.
4) the (noteout "from Max 1") contraption sends only "on" events, which I use to set an amp or mixer channel volume. I then remains set to this1 volume until another hit on the same note changes it.
5) "makenote 1 5 3" makes a new MIDI note all together - mostly identical to the one received from the pad, but only 5 milliseconds long - that's short enough for starting the file player (with "inverted" checked) without a noticeable delay.

In AudioMulch, I use two different MIDI inputs to read  "from Max 1" and  "from Max 2". I got some pretty wild and wonderful "drum" kits...

Somebody with Max or PD should be able to put this together for you as a stand-alone application in less than half an hour.