Enable Audio Hotkey / Command

5 posts / 0 new
Last post
Gutz's picture
Joined: October 23, 2009

first let me say this is a great app :)

i have a little issue which i think won't be such trouble to solve
im using audiomulch as a vst host to run my car-pc audio crossover/eq and such

im having a problem that when i resume from hibernate i get no sound and i need to press the enable audio twice ( once to turn it off and once to turn it back on )
the problem is actually with my soundcard drivers ( asio not coming back as fast i guess ) but there is not solution yet for that

so i found a workaround in which im using a script that focuses on audiomulch window
press ALT+C ( bring control menu )
and then ENTER ( press on enable audio )

its working but not 100% of the time ( sometimes it loses focus so i only get half of the actions and stuff like that )

what im requesting is one of the either :
1.a way to use hotkey to switch enable-audio button
2.outsite command line switch ( or a app ) to switch the enable-audio button

another idea that came to my mind is maybe add an option to delay the asio driver usage when resuming from hibernation ( if thats even possible )

again i really love audiomulch
thank you guys for this great app

and if you can solve my little issue it would be fantastic :)

thanks again

Ross B.
Ross B.'s picture
Joined: April 11, 2009

Hi Gutz

The shortcut is Alt+C+A -- not sure if your script can send that all as one command but might be safer than Alt+C, Enter.

You can set AM to enable audio when it starts up (see the startup options in the settings dialog). It (might) be easiest to arrange for your script to kill AudioMulch before hibernation (or on wakeup) and to restart AudioMulch.

At the moment AM doesn't do anything on hibernation so its completely the ASIO driver's problem to keep things working.

Let me know if any of the above works for you. If not I'll try to work out something else.


Gutz's picture
Joined: October 23, 2009

wow thanks for the fast response

the Alt+c+a worked a little bit better than Alt+c+enter but not good enough ( cuz it still opens the control list dialog )

i did tried the kill and run option before and don't know why i not used it
but now i managed to get it working pretty darn good
the only issue is that i have to wait an extra couple of seconds ( till audiomulch loads )

its a pretty good solution for now :)
if you have some spare time if would be great if you could compile an external command line exe that just enable/disable audio without the need of focusing on the audiomulch window
don't know if its actually possible but its the best workaround i can think of ( till the audio drivers will get fixed )

thanks again man :)

Gutz's picture
Joined: October 23, 2009

Bringing this up again , wanted to see if there is any progress with this?

Ive been using the kill-restart option and its adding something like 10 sec's to my boot time and its sucks..
i would love to solve it in another way..


Ross B.
Ross B.'s picture
Joined: April 11, 2009

This should be resolved in AudioMulch 2.1:
* Windows: Audio, midi and network devices are disabled/enabled on APM suspend/resume (i.e. the audio device closes when the computer goes to sleep).