Re: Issue with a performance need.

5 posts / 0 new
Last post
ListenHear's picture
Joined: November 16, 2009

I can't seem to find the answer to a issue I'm encountering – I open a patch (a) and, record an automated fade-out cue on a mixer contraption using a midi controller, then during a performance I activate this fade and once it's completed I open another patch (b) using the document switcher. Later in the performance I want to return to patch (a) but I require it to be back in its initial state not the post-automated fade state. Also when I close Audiomulch and then reopen at a later time it seems to always open in the last state used (in this case, post-automated-fade) and not 'the ready to go from the top' (pre-automated-fade) setting. Basically, once a document/patch has been used and navigated away from I need it to be back to it's original state when I re-open it.

Am I missing something obvious? Is there a solution to this?


Steven Brown

Head of the Sound Design Working Group - OISTAT
Board Member - The Association of Sound Designers
Head of Sound - The Royal Exchange Theatre Company

twitter @listenhear

Lume's picture
Joined: September 10, 2011

I haven't used the Document Switcher yet, but in Settings there are Document Switcher options. I imagine you want to use "Discard changes without prompting".

Ross B.
Ross B.'s picture
Joined: April 11, 2009

Hello Steven,

As Lume says, there is a setting on the Document Switcher page of the settings/preferences that controls how this works. For the behaviour you want, you should select "Discard changes without prompting".

Please let us know if this resolves the issue for you.


ListenHear's picture
Joined: November 16, 2009

I'm afraid this doesn't seem to resolve the issue, as when I return to the document (having selected and saved the "Discard changes without prompting" option) the rotary master control of the mixer is still in it's post-automated (at infinite) fade state.

Is there a 'clear automation' function?

The (very simple) routine is this -

1. Start file player (a) with a midi note on.
2. Start the previously recorded automated fade (simply fading out the audio using the master rotary control on a mixer) using, once again, a midi note on command.
3. Stop file player (a) using a midi note off command.
4. Change to another document by sending a program change command.
5. Start file player (b) in the new document with a midi note on.
6. Stop file player (b) using a midi note off command.
7. Open the first document again with a program change.

I'm sending the midi commands using a piece of software called SCS ( Simply playing and fading out sound files can easily be done within this software but I want the ability to place VST effects/Audiomulch contraptions in the signal path and also have the ability to record fades in rehearsals rather than opt for the simple fade choices contained within (the otherwise excellent) SCS. I ultimately want to explore using the meta surface to control complex EQ changes and fades which is why the option to return to an 'clean' initial state is crucial.

I'm using version 2.2 Public Beta.

I'll keep plugging away at this issue (and try to clarify that it's not something obvious which I'm doing!) but any further thoughts and possible solutions would be appreciated.

Many thanks,


Ross B.
Ross B.'s picture
Joined: April 11, 2009

A couple of thoughts:

Try triggering the file player to start from an automation channel rather than separately triggering it from MIDI. I'm not sure if that resolves your issue, but it seems like a better way to keep automation and file playback in sync.

Make sure when you save each document you save it with the mixer knobs in the position you want them to be in. If you save the document with the faders turned down (perhaps because the automation was at the end when you saved it) then that's how it will load.